Technical Requirements

Ahead of a Waahi implementation, we ask that you make sure that any required technical components are installed and ready.

Installation Requirements

Basic Installation

  • Externally facing ArcGIS Enterprise 10.3 or higher OR ArcGIS Online
  • Esri’s Web AppBuilder (Developer Edition)
  • Web server, with Windows 7 or later, or Windows Server 2008 R2 or later
  • Internet connection
  • SSL Certificates (for HTTPS access)

See more important information about installing Web AppBuilder.

Advanced Installation*

*Using widgets like the Advanced Share and Advanced Print requires some advanced tools.

Portal or AGOL content you’ll need:

  • Relevant map services published
  • Relevant web maps configured
  • A Portal or AGOL group containing basemap web maps, for the Basemap Switcher widget
  • Favourite app Portal or AGOL groups created (for the App Switcher widget and/or the
    gallery)
  • Print geoprocessing service set-up on ArcGIS Server (or use Esri default)
  • Geometry service set-up on ArcGIS Server (or use Esri default)

Don’t worry, we’ll discuss all of these technical requirements with you before the implementation.

Supported Browsers

In alignment with the Esri Web AppBuilder app browser support, Waahi is supported in the following browsers:

  • Chrome
  • Firefox
  • Safari 3 and later
  • Edge
  • Internet Explorer 11
  • iOS Safari
  • Chrome for Android

Get Started

Want to find out more, request a demo or learn how Waahi can power your organisation?